Installing Windows Vista on a Raid 0

Published April 29, 2007 on adamfortuna

    When I first installed Vista back in February I had my share of problems trying to get it working. I had recently upgraded to a DFI LANPARTY UT nF4 SLI-DR Expert Socket 939 NVIDIA nForce4 SLI ATX AMD Motherboard and the nForce Raid drivers weren't cooperating during my very hastily done install. At the time they didn't want to work right with my two sata drives I was planning to throw Vista on, even after maybe a dozen seemling successful attempts. Today though I was able to try again and get everything working in almost no time. The main source of help was a post on Vista and nVRaid at nforcershq.com. This is for a Windows Vista Ultimate x64 install, so I grabbed the latest Official nForce x64 Vista Drivers and loaded them onto a thumb drive. Next I made sure that my Raid was properly configured using the easy setup tools provided before boot by my mortherboard. These have to be setup first before the install, which means you'll need to throw a little caution to the wind if this is your only computer. After that point there's no turning back. Boot up from CD into Vista, selecting the x64 install at the opening screen and later when prompted for your specific version (if applicable). At the point where it asks to choose where to install Vista it saw my two drives that were actually one striped raid. I loaded up the three drivers as specified in that guide in the following order: "SATA_IDE/NVIDIA nForce Serial ATA Controller”, "SATARAID/NVIDIA nForce RAID Controller” and "SATARAID/NVIDIA nForce RAID Device”. After the first one it did see my raid as a single hard drive, but without the last two loaded you will run into problems later on during the install. After that Vista does the rest! As far as a speed difference, that's yet to be determined. There's some serious questions about the performance of the x64 raid compared to the x86, from what I've read putting it much slower. Vista itself runs blazingly fast for me though, and even during the 3 months I'd previously had it installed I'd been happy enough to buy a license. If you're looking for a way to "try before you buy” there's a very simple way to extend your grace period to 120 days giving you more than enough time to get settled in and decide if it's worth the cash. Vista's new "Windows Experience Index” previously rated my primary hard disk performance at 5.1 (36gb raptor), but now with a pair of them in raid 0 it's raised to a very respectable 5.9. Windows Experience scores only go up to 5.9 at the moment, so if yo'ure looking for one way to max them out- - dual Raptor drives is one possibility. Now if I can just get that wireless card to see my network I'll be all set.